Issues while deploying contract through Tron IDE

Hi everyone, I’m participating in the hackathon, and I’m having trouble deploying smart contracts. I wanted to deploy two separate contracts, one deploys just fine, but while deploying the other I get the following message

Send transaction failed: Broadcast failed . if you use an injected provider, please check it is properly unlocked. 

Unlocking the wallet is not the issue, I’ve confirmed that. Any ideas how I can solve this? Without this my team’s work on the hackathon is suspended.

Btw, I’m using Tron IDE to deploy and deploying to the Shasta testnet.


I resolved the issue by adjusting my fee limit in Tron IDE. If you set it to too low it will error out by saying OUT_OF_ENERGY, if you set it to too high then it will fail with the error I originally posted. So you have to keep in mind to not set it too high. That resolved the error for me.


You can ask on Telegram Telegram: Contact @TronOfficialDevelopersGroupEn

Or tag @admin.hackathon


Let’s see your contract code!

1 Like

I think this idea will be good to ask on telegram grp.


tron ide sux unfortunately

Hey everyone, the issue got fixed. Most probably it was because I increased the fee limit to a very high value while deploying.


Glad to hear! Excited for what you build.

1 Like

This is a good question

1 Like

Thank God the problem has been solved, don’t you think it would be nice if you drop how it was solved incase someone else comes across such issues in future

1 Like

Thank you! Yeah you’re right, I did share what was the issue. I’ll update the OP with a more detailed explanation just in case. Thanks for the reminder :smiley:

This is a nice idea I think…

1 Like